Simple Agitated TankΒΆ

 

Model Set-up

  1. Start M-Star Build via Windows Start Menu

  2. Build -> Define Outer Geometry

    1. Choose: Vertical Cylinder

    2. Click on the BoundingGeometry component in the Model Listing

    3. Specify tank diameter: 1.0 m

    4. Specify tank side wall height: 1.0 m

    5. Specify bottom shape: Dish

    6. Specify floor depth: 0.1 m

    7. Specify baffle count: 4

    8. Specify baffle width: 0.05 m

    9. Specify fluid height: 1 m

    10. Specify head space: 0. m

  3. Build -> Define Moving Geometry

    1. Choose: Pitch Blade Impeller

    2. Specify impeller diameter: 0.35 m

    3. Specify shaft length: 0 m

    4. Specify blade angle: 45 degrees

    5. Specify impeller speed: 60 RPM

    6. Specify impeller start-up ramp: 0 s

  • The tank side wall height plus the tank floor depth gives the total tank height

  • The impeller mount point and orientation can be tuned via Ref. Point and Ref. Axis

  • Multiple impellers with unique positions, orientations, and rotation axes can be defined

  • Setting either the shaft diameter of shaft length to zero eliminates the shaft

  • The ramp evolves the impeller from rest to the set speed via a quarter sine wave

  1. Select the Simulation Component

    1. Specify Resolution on Reference Length: 150

    2. Specify runtime: 60 s

    3. Specify CheckPointInterval: 10 s

    4. Specify data output: 0.005 s

    5. Specify slice output: 0.05 s

    6. Specify volume output: 1 s

  • The simulation lattice is uniform with a resolution defined by Resolution on Reference Length

  • The timestep is calculated from the resolution, impeller speed, and Courant number

  • Data output describes the output frequency of forces, torques, and blending

  • Slice/volume output describes the output frequency of visualization files.

  • The CheckPointInterval describes the print frequency of simulation restart files.

Model Processing

  1. Solve -> Run Solver

    1. Choose an appropriate output location

    2. Specify an appropriate number of cores

  • The solver may produce several GB of data, make sure ample disc space is available

  • Terminate the simulation at any time by closing the black command prompt window

  1. File -> Save As

    1. Save your model with an appropriate name as a .3dm file

Visualzation and post-processing

  1. Start M-Star Post via Windows Start Menu

  2. Browse to your output directory in Windows

  3. Open the slices.txt in ParaView

  4. Press the MStarPost button.

  5. Click on the Impeller0 tab

    1. Examine the time-evolution of the force on the impeller, Fx, Fy,Fz

    2. Examine the time-evolution of Np, the impeller power number.

    3. Examine the time-evolution of Nq_side, Nq_top, and Nq_bottom the three pumping numbers

  • The Fy force should be greater in magnitude than Fx and Fz, due to axial thrust

  • The initial Np should be high, as the impeller must accelerate an initially quiescent fluid.

  • Negative pumping numbers imply flow into the swept volume.

  1. Click on the 3D View tab

    1. Press the green play button to animate the sequence image132

    2. Change the view from 2D to 3D by pressing the 3D button below the 3D View tab heading: image209

    3. Hold down the right mouse button to zoom

    4. Hold down the left mouse button to rotate

    5. Hold down the center mouse button to pan

    6. Zoom to fit by clicking the zoom icons: image130

  • Frame sequences or pre-compiled movies can be generated from File->Save Animation.

  • Updated data can be imported by right clicking files in the browser and selecting Reload Files